Connect embedded modem to cellular network on bootup

I have a Dell E6430 ATG with an embedded Novatel wireless card on a the Verizon network.

The problem is I need to always have the wireless card establish a connection to the Verizon Network upon initial boot up and BEFORE to the user(s) log in. They need to use a fingerprint reader to authenticate to the domain and the VPN can't make a secure connection unless the connection has already been established.

There many articles about establishing a connecting before log on but they involve getting the Wireless profile and adding it to the registry... entries in the GPO... using Netsh wlan show profile, configuring Dell Mobile Broadband Cards to Auto-Connect Using NDIS in Windows etc... but none of them work.

There has to be a way of starting the Novatel modem and establishing a connection before the user logs in!
I also looked is there a way to have the Dell mobile broadband utility 3.0 instead of the Novatel utility connect to the Verizon network on boot prior to user log on but so luck?

I'm missing something, this can't be that hard or impossible.HELP!



My USB wireless will not and has never started before I log in.

The wireless tricks work for Wi-Fi but not cellular.

How do people start their machines if NOT near or on the domain? They must be able to use their machines. Have them start that way, then attach the cellular, then log in.

Also, consider having the machines not on the domain at all. Then attach to folders with a desktop script. I have done this and it works.



My USB wireless will not and has never started before I log in.

The wireless tricks work for Wi-Fi but not cellular.

How do people start their machines if NOT near or on the domain? They must be able to use their machines. Have them start that way, then attach the cellular, then log in.

Also, consider having the machines not on the domain at all. Then attach to folders with a desktop script. I have done this and it works.



This is NOT a USB wireless but Embedded wireless card in the laptop mounted in a vehicle and the need to be connected to the Domain is a must, at least during initial boot, Once they are connected to the cellular network, the VPN can start and they can authenticate to the Domain using a fingerprint reader that stores their bio-metric information for all users in Active Directory. Occasionally the laptop may be used by someone who has not logged into it previously - therefore, they cannot rely on cached credentials to allow them onto the system.
The whole exercise by the numbers is:1. turn on and boot laptop, during boot cellular connection is made prior to user using fingerprint reader or username/password if fingerprint reader fails.
2. User uses fingerprint reader to login. VPN (Forticlient) is set to auto connect and create secure tunnel.
3. During login users fingerprint profile authenticates to Active Directory.
4. Once VPN is established, they are always connect to domain and everything works fine until they turn the laptop off.

The problem is the initial startup of the laptop and getting the sequence right.

My initial conversations with Dell, Verizon and Novatel was not productive.



My USB wireless is the same as your embedded wireless. Neither are Wi-Fi if I understand you correctly. See what others say but I use what you are using and it seems like trying to push a rock uphill to make that device connect before the domain kicks in. So I work around it.



Sorry for the long delay but I'e taken a different track using Forensit



Using Forensit

Share this

Related Posts

There was an error in this gadget