Windows Server 2008 (Standard) Server Keyboard Drops Repeatedly

We have a server running Windows Server 2008 Standard attached to a KVM (it runs our Polaris ILS system). For a reason as yet undiscovered by me, the keyboard sporadically cuts out. The mouse still works during these disruptions and both it & the keyboard work normally with the other servers on the KVM.

We've attempted to plug the server into another port on the KVM and attach a keyboard & mouse to it directly. No luck with either of those potential fixes. The keyboard will pick up after a reboot, but, inevitably, it will stop working again. I see no pattern in the amount of time it works before failing.



Is your KVM using PS2 ports or USB ports? It could be that if you are using PS2 ports that the keyboard port is going bad on the server.



Is your KVM using PS2 ports or USB ports? It could be that if you are using PS2 ports that the keyboard port is going bad on the server.



The KVM uses PS2.

The keyboard & mouse we plugged directly into the server was USB, though. The problem persisted when we did that; the mouse was fine, but the keyboard was totally unresponsive.



We had a similar problem that we cured by adding more memory. We installed several virtual servers and the I/O caused memory shortages even though the single server by itself looked like it had enough.



Interesting. This server isn't one I manage, but I was asked about the keyboard issue. I'll pass that along to the lady who manages it.



Bill - looks like you're correct. When I told her about the possibility of it being linked to RAM, she said she was running low on that server. That makes total sense because a reboot fixes it every time. We're in the process of migrating to virtual servers on new equipment. Hopefully we can finish up that project soon and get rid of this box.

Share this

Related Posts

There was an error in this gadget