PKI Template has been configured but not being deployed ?

Hi Everyone,

I have deployed a 3-tier PKI infrastructure in a Windows 2008 R2 envinronment. There is a GPO in place for auto-enrollement of certigicates via a GPO. Attached to the GPO is a security filter which has a group that only contains computer objects to deploy certificates to. I have copied the Computer template, duplicated and called 'Test AE'. When I open the certificate on the test server, the 'Geneeral' tab displays the purpose of the certificate as 'All applications policies'. If I click on the 'Details' tab and scroll down, where it details 'Certificate Template Name' the value is SubCA. I expect the 'Certificate Template Name' to be 'Test AE' ?

In the AD CS management console under 'Certificate Templatres' it does have the 'Test AE' displayed. Also, the template on the security setting has the group I associated in AD to the GPO. I have the group with 'Read','Enroll' and 'Autoenroll' configured.

Does anyone have any ideas as to why this is happening ?



The certificate you seen is from subordinate CA and I don't think it is got deployed through GPO
Delete that cert from test server and run gpupdate /force again to see what certificate is getting installed

do not duplicate computer certificate, it is default certificate template
U can directly use it via GPO, in GPO, under "computer configurationpolicieswindows settingssecurity settings public key policies" enable certificate enrollment and auto enrollment
Then navigate to automatic certificate request settings and add "computer" certificate template there which will take care of auto enrollment
https://technet.microsoft.com/en-us/library/dd379529(v=ws.10).aspx

If you wanted just client authentication, do above auto enrollment settings in policy and duplicate workstation authentication certificate and check if it works
Because computer template contains both server authentication and client authentication



The certificate you seen is from subordinate CA and I don't think it is got deployed through GPO
Delete that cert from test server and run gpupdate /force again to see what certificate is getting installed

do not duplicate computer certificate, it is default certificate template
U can directly use it via GPO, in GPO, under "computer configurationpolicieswindows settingssecurity settings public key policies" enable certificate enrollment and auto enrollment
Then navigate to automatic certificate request settings and add "computer" certificate template there which will take care of auto enrollment
https://technet.microsoft.com/en-us/library/dd379529(v=ws.10).aspx

If you wanted just client authentication, do above auto enrollment settings in policy and duplicate workstation authentication certificate and check if it works
Because computer template contains both server authentication and client authentication









Share this

Related Posts

There was an error in this gadget