Server 2012 connector didn't join computer to domain

We have a new server running Windows 2012 Server Essentials. On one of the workstations, running Windows 8.1, we ran the connector software and received the message that the computer was successfully connected to the server. However under computer properties it still says that it's a member of WORKGROUP. And we never received the message that the stand-alone profile was being migrated. I uninstalled the connector and reinstalled it and got the same result.



The connector does not move profiles when installed on 8 or 8.1. It can only move profiles on Win7. So that is perfectly normal (and it actually pops up a dialog box that explains this when the connector is installed the first time.)

As far as not being in a domain, I'm guessing you are not running 8.1 Pro or Enterprise. The connector cannot overcome the basic limitations of the OS and home editions (non-pro/business/enterprise) OSes have never been able to join a domain. But essentials, meant for small businesses that may be introducing a server into a workgroup where "home" computers were bought at the local Best Buy, does allow the connector to be installed and therefore provide some basic services. So again, normal for those editions of the OS.



The connector does not move profiles when installed on 8 or 8.1. It can only move profiles on Win7. So that is perfectly normal (and it actually pops up a dialog box that explains this when the connector is installed the first time.)

As far as not being in a domain, I'm guessing you are not running 8.1 Pro or Enterprise. The connector cannot overcome the basic limitations of the OS and home editions (non-pro/business/enterprise) OSes have never been able to join a domain. But essentials, meant for small businesses that may be introducing a server into a workgroup where "home" computers were bought at the local Best Buy, does allow the connector to be installed and therefore provide some basic services. So again, normal for those editions of the OS.



Thank you! I didn't even realize there are those additional versions of the OS. Very good answer, I might add...



Excellent, lucid answer.





Share this

Related Posts

There was an error in this gadget